Delayed validation and delivery of submitted documents

Incident Report for FormsByAir

Resolved

We've applied a fix and all services are now operating normally
Posted Sep 04, 2026 - 14:33 NZST

Investigating

We are currently investigating an issue with Azure Service Bus that is causing delayed validation and delivery of submitted documents
Posted Sep 04, 2026 - 13:36 NZST
This incident affected: Forms.