Connectivity issues

Incident Report for FormsByAir

Postmortem

FormsByAir was impacted by a major global outage with Microsoft Azure this morning, preventing access to our website, portal and all forms hosted on our platform.

Our monitoring indicates that this started around 5am NZT. We created an incident on our status page at 7.35am NZT, providing additional updates as available from Microsoft.

We observed close to normal service from 9.30am NZT, with sporadic requests and slow-downs up until midday. Microsoft have now flagged this issue as fully mitigated.

The cause of the issue per Microsoft was an inadvertent update to Azure Front Door. This is a critical service that sits in front of our web servers for edge caching, SSL offloading and protection against attack. Perhaps the bigger issue was the time involved in recovering from the issue once identified, something I'm sure Microsoft will be reviewing closely.

We looked at temporarily routing traffic around Front Door, but considered the risk of such a change to outweigh the benefit, particularly as things started coming back online from 9.30am onwards.

We will of course review our architecture in the wake of this event, and seek guidance from Microsoft and others. This is an ongoing challenge for all online services. We've had almost 100% uptime for the last 2 years, and continue to have confidence in Microsoft and Azure.

Posted Oct 30, 2025 - 13:44 NZDT

Resolved

Microsoft have now flagged this issue as fully mitigated. All of our services appear to be operating normally.
Posted Oct 30, 2025 - 13:42 NZDT

Update

Microsoft have advised that Azure Front Door is now operating above 98% availability. We are seeing normal service across our platform, but will continue to monitor until Microsoft advise that this has been fully mitigated, expected to be within the next hour.
Posted Oct 30, 2025 - 12:53 NZDT

Update

We are continuing to see improved connectivity to our website and forms, but pages may be slower to load in some cases
Posted Oct 30, 2025 - 09:33 NZDT

Monitoring

We're starting to see signs of recovery, some users may be able connect to our portal and forms. We are continuing to monitor the situation https://azure.status.microsoft/en-us/status
Posted Oct 30, 2025 - 08:25 NZDT

Investigating

We are currently investigating a connectivity issue to our website and forms. This appears to be related to a major outage with Azure Front Door which our system uses, see https://azure.status.microsoft/en-us/status
Posted Oct 30, 2025 - 07:46 NZDT
This incident affected: Website and Forms.