Intermittent connection issues
Incident Report for FormsByAir
Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 13:46 NZST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2023 - 13:20 NZST
Investigating
We are currently investigating this issue
Posted Jun 23, 2023 - 13:08 NZST
This incident affected: Website and Forms.