Connection issues
Incident Report for FormsByAir
Resolved
All services are now operating normally
Posted Nov 01, 2023 - 12:33 NZDT
Investigating
We are currently investigating this issue.
Posted Nov 01, 2023 - 12:26 NZDT
This incident affected: Website and Forms.