GBG Cloudcheck partial outage

Incident Report for FormsByAir

Resolved

Normal service has been restored
Posted Jul 07, 2025 - 09:10 NZST

Investigating

We've verified with GBG that they are experiencing a service interruption which is preventing ID verifications, they are working on a fix
Posted Jul 07, 2025 - 08:51 NZST
This incident affected: GBG Cloudcheck.